Error: This experience uses an unsupported version of Expo. You may need to update Expo Client on your device.

Sometime when Expo releases new update with new features, you may have the issue of Expo Client expired when you run your app on Simulator. What you should do it restarts the simulator (Hardward > Restart), deleted Expo app on Simulator and run the application again. Next time when you run, it will install latest Expo client to the Simulator.

Posted by justinpham

Leave a Reply